Zikula Core CMS 2.0.12 vrijgegeven - Hier is installatie op Ubuntu 16.04 | 18.04 | 18.10

  • Dylan Parker
  • 0
  • 3119
  • 199

Zikula, een open source content application framework (CMF) gebouwd op Symfony, is onlangs bijgewerkt naar versie 2.0.12 en 1.5.9 om twee beveiligingsproblemen op te lossen ...

Als u momenteel uw websites en apps op Zikula gebruikt, wordt u aangemoedigd om zo snel mogelijk te upgraden om deze bugs op te lossen ... Een van deze oplossingen heeft betrekking op het Symfony-framework ... het is een oplossing met betrekking tot de openbaarmaking van het volledige pad van geüploade bestanden ... en de andere heeft betrekking op de Zikula-sjabloon ...

Kijk voor meer informatie over deze update op de releasepagina's hier en hier ... Hieronder vindt u een lijst met items die met deze release zijn opgelost ...

Beveiligingsoplossingen van Symfony:

  • Openbaarmaking van volledig pad van geüploade bestanden (CVE-2018-19789).
  • Open omleidingslek bij gebruik van Security \ Http (CVE-2018-19790).

Oplossingen:

  • Gebroken ondersteuning voor aangepaste bloksjablonen in thema's opgelost.

Voor degenen die Zikula willen installeren, zouden de twee onderstaande berichten een geweldige plek moeten zijn om te beginnen ... Ze laten je zien hoe je Zikula installeert met Apache2 of Nginx HTTP-servers ...

Installeer Zikula met Apache2-ondersteuning

Als u wilt leren hoe u Zikula CMS met Apache2-ondersteuning installeert, gebruik dan de onderstaande link:

Installeer Zikula CMS op Ubuntu 16.04 | 18.04 | 18.10 met Apache2, MariaDB en PHP 7.2

Installeer Zikula met Nginx-ondersteuning

Als je liever Zikula met Nginx HTTP-ondersteuning hebt, gebruik dan de onderstaande link:

Stel Zikula CMS in op Ubuntu 16.04 | 18.04 | 18.10 met Nginx, MariaDB en PHP 7.2-FPM

Zikula upgraden

Als je Zikula al hebt geïnstalleerd en je wilt je bestaande installatie upgraden, dan moet je hun ondersteunende helpartikelen volgen om te beginnen ...

U wilt ook een back-up maken van de inhoud en database van uw huidige site voordat u probeert uw site te upgraden ... Voor sites die Composer gebruiken om Zikula te installeren, update dan het versienummer in het composer-bestand en voer de onderstaande opdrachten uit ...

sudo composer update

Dat zou ervoor moeten zorgen dat Zikula wordt bijgewerkt ...




Niemand heeft nog op dit artikel gereageerd.

Een verzameling nuttige informatie over het Linux-besturingssysteem en nieuwe technologieën
Nieuwe artikelen, praktische tips, gedetailleerde recensies en handleidingen. Voel je thuis in de wereld van het Linux-besturingssysteem